Fiesta-Si.com
http://www.fiesta-si.com/forums/

Back after 3 years with a si again!
http://www.fiesta-si.com/forums/viewtopic.php?f=5&t=25700
Page 2 of 3

Author:  bensouthport [ Mon Jan 12, 2015 10:10 am ]
Post subject:  Re: Back after 3 years with a si again!

good repair work mate.
you got any plans or you just going to enjoy it?

Author:  Seanymk2 [ Sat Jan 24, 2015 12:08 am ]
Post subject:  Re: Back after 3 years with a si again!

I think because of the condition of the shell I won't be chucking money at it really, it already has coil overs 2.0ltr engine and few other nice bits like the sound system, now all the welding is done I'm going to use it as my daily car and focus on getting my mk2 finished as thats the car I dont mind throwing money at lol

Author:  Seanymk2 [ Sat Jan 24, 2015 12:11 am ]
Post subject:  Re: Back after 3 years with a si again!

I also do have a bare mint mk3 shell in my unit so I may use the si until it's unrepairable and build my shell with the bits from the si but will have to see how she gets on lol

Author:  Seanymk2 [ Thu Feb 05, 2015 2:43 pm ]
Post subject:  Re: Back after 3 years with a si again!

Thanks!!
All the welding is done now cambelt and alti belt has been changed, new plugs and leads new alti and idler pully new discs and pads, all that's left to do now is bleed the brakes and mot it :) can't wait !!!

Author:  onslack [ Thu Feb 05, 2015 2:49 pm ]
Post subject:  Re: Back after 3 years with a si again!

nicely done buddy, getting there :thumbsup:

Author:  Seanymk2 [ Thu Feb 05, 2015 2:51 pm ]
Post subject:  Re: Back after 3 years with a si again!

It's also now very very thick in under seal and all the welds have been sealed before hand! Also fitted some recaro's I had in my previous mk3 with some swanky seat covers :)

Image
Image
Image
Image

Author:  bensouthport [ Mon Feb 09, 2015 12:58 pm ]
Post subject:  Re: Back after 3 years with a si again!

looks spot on mate

Author:  Seanymk2 [ Tue Feb 24, 2015 8:39 pm ]
Post subject:  Re: Back after 3 years with a si again!

Cheers mate. :) just need to get it running properly now lol

Author:  bensouthport [ Thu Feb 26, 2015 9:26 pm ]
Post subject:  Re: Back after 3 years with a si again!

how's it running now?

Author:  Seanymk2 [ Thu Mar 05, 2015 12:34 am ]
Post subject:  Re: Back after 3 years with a si again!

It was running rough as a bag of nails with a horrendous flat spot and couldn't figure out why, iv had it apart three times to check timing and what not and all was fine... And then yesterday I unplugged the maf sensor and the flat spot went away and it now runs and revs free as a bird so I may run it like that until I can sort a new one unless someone can confirm it's ok to use without one in that case I'll leave it aha

Also noticed I don't have a belt on my abs pump and kind seem to find out anywhere?

How's your si Ben?

Author:  Seanymk2 [ Fri Mar 06, 2015 2:55 am ]
Post subject:  Re: Back after 3 years with a si again!

Image

Pov spec bumper fitted so I don't smash the cossie splitter to bits on the brake rollers!

Author:  bensouthport [ Mon Mar 09, 2015 9:50 am ]
Post subject:  Re: Back after 3 years with a si again!

is it not worth getting a replacement maf? You tried cleaning the pins on it?

no idea about yours abs mate unfortunately.

Pov actually looks good lol! Need to get my cossie bib fitted...

Mine's ok mate. Connected up the new battery yesterday and filled her with coolant, just a case of draining old fuel, putting some fresh stuff in then hoping for the best!

Author:  Seanymk2 [ Wed Mar 11, 2015 2:00 am ]
Post subject:  Re: Back after 3 years with a si again!

I know! If the lower valance was painted I'd leave it PoV spec lol but the front cossie bib does look the nuts :D
Hope you get yours up and running soon (y) I'll be coming up to southport to see some mates of mine when the si is done as they Wana see It

Author:  Seanymk2 [ Mon Mar 30, 2015 12:07 am ]
Post subject:  Re: Back after 3 years with a si again! !!mot on the 1st!!

So it's been a lot of work but finally it's all ready for mot iv drove it a little around my unit/yard and I cannot wait to get it out!!

Also fitted some hids my brother got me for Christmas
Had to fit the PoV spec bumper too so it doesn't smash the cosworth splitter on the brake testers

Image

Image

Image

Cheers for looking :)

Author:  bensouthport [ Mon Mar 30, 2015 11:52 am ]
Post subject:  Re: Back after 3 years with a si again!

give me a shout when you're over here mate!

Author:  Seanymk2 [ Mon Mar 30, 2015 2:35 pm ]
Post subject:  Re: Back after 3 years with a si again!

Haha yeh I will do mate :)

Author:  onslack [ Wed Apr 01, 2015 2:15 pm ]
Post subject:  Re: Back after 3 years with a si again!

Looking good buddy!

How did the mot go?

Author:  Seanymk2 [ Thu Apr 02, 2015 12:47 am ]
Post subject:  Re: Back after 3 years with a si again!

Cheers mate!!

And super news, she passed with no advisorys :)

Image


Image

made up with how it drives and the 1.1 gearbox is.... Eventful.. few rattles to sort and fit the si bumper but happy with it :)

Author:  meilack [ Thu Apr 02, 2015 7:38 am ]
Post subject:  Re: Back after 3 years with a si again!

awesome ;)

Author:  Seanymk2 [ Thu Apr 02, 2015 1:47 pm ]
Post subject:  Re: Back after 3 years with a si again!

Cheers :)

Been out today and washed for the car for the first time in God knows how long.. Still no si bumper as can't tax it till my logbook returns :/

Image

Image

Image

Page 2 of 3 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/